The following series of commands demonstrates how to set the PVID of an AIX disk to a specific value like “0123456789abcdef”:
Note: Setting PVID like this should be avoided normally. It may cause unwanted consequences in your environment.
# DISK=hdisk2 # chdev -l $DISK -a pv=clear hdisk2 changed # lspv | grep hdisk2 hdisk2 none None # perl -e 'print pack("H*","0123456789abcdef");' > /tmp/pvid # cat /tmp/pvid | dd of=/dev/$DISK bs=1 seek=128 8+0 records in. 8+0 records out. # rmdev -dl $DISK hdisk2 deleted # cfgmgr # lspv | grep $DISK hdisk2 0123456789abcdef None # mkvg -fy testvg hdisk2 testvg # crfs -v jfs2 -g testvg -m /testfs -a size=20G File system created successfully. 20970676 kilobytes total disk space. New File System size is 41943040 # mount /testfs # lspv $DISK -l hdisk2: LV NAME LPs PPs DISTRIBUTION MOUNT POINT fslv03 160 160 00..108..52..00..00 /testfs loglv02 1 1 00..01..00..00..00 N/A
Again , This task not recommended to manually, it’s prefer to let system make it automatically
Reference :
https://www.ibm.com/developerworks/community/blogs/mehdi/entry/how_to_set_the_pvid_of_a_disk_to_a_specific_value21?lang=en
Leave a Reply